通达信指标公式大全画线主图公式

来源:中金指南网

指标公式用法

全画线主图公式用于K线主图,使用该指标可以有效发现个股支撑点位和压力位,如上图中横向黄线是支撑位,分析下这2个支撑位是有效的,股价跌到此位置跌不动了。蓝色的压力线,股价突破压力位后一路撑撑往上涨,在压力位受阻时却涨不动,神奇吧。

指标公式案例

全画线主图公式
全画线主图公式

指标公式源码

AA05:=MA(C,5),COLOR0099CC;
五日乖离率:=(C-AA05)/AA05*100;
BB05:=ATAN((AA05/REF(AA05,1)-1)*100)*180/3.1416;
速度5:=SMA(EMA((AA05-REF(AA05,1))/REF(AA05,1),3)*100,3,1);
加速度5:EMA((速度5-REF(速度5,1)),3),NODRAW;
AA10:=MA(C,10);
AA20:=MA(C,20);BB10:=ATAN((AA10/REF(AA10,1)-1)*100)*180/3.1416;
AA30:=MA(C,30);
三拾日乖离率:=(C-AA30)/AA30*100;
VAR11:=(AA20-AA30)>REF((AA20-AA30),1)

AND AA20>REF(AA20,1) AND AA30>REF(AA30,1);
VAR22:=(AA30-AA20)<REF((AA30-AA20),1) AND AA20<REF(AA20,1) AND

AA30<REF(AA30,1);
BB30:=ATAN((AA30/REF(AA30,1)-1)*100)*180/3.1416;
强势狙击:=FILTER(BB30>30 AND BB10>45 AND

CROSS(BB05,60),10);
加仓:=FILTER(COUNT(CROSS(BB05,30),5)>=1 AND

AA05>REF(AA05,1) AND 三拾日乖离率>REF(三拾日乖离率,1) AND

AA10>REF(AA10,1)

AND 加速度5>REF(加速度5,1) AND 速度5>REF(速度5,1) ,10) ;
清仓:=FILTER(COUNT(CROSS(30,BB05),5)>=1 AND (C>AA30 OR O>AA30) AND

AA05<REF(AA05,1) AND 三拾日乖离率<REF(三拾日乖离率,1) AND

AA10<REF(AA10,1),10);
DRAWICON(加仓 ,LOW*0.99,23);
DRAWICON(清仓 ,HIGH*1.01,15);
DRAWICON(强势狙击 ,LOW*0.99,13);
TYP := (HIGH + LOW + CLOSE)/3;
CCI1:=(TYP-MA(TYP,6))/(0.015*AVEDEV(TYP,6));
差值1:=ABS(REF(CCI1,1)-CCI1),LINETHICK0;
CCI2:=(TYP-MA(TYP,10))/(0.015*AVEDEV(TYP,10));
差值2:=ABS(REF(CCI2,1)-CCI2),LINETHICK0;
CCI3:=(TYP-MA(TYP,20))/(0.015*AVEDEV(TYP,20));
差值3:=ABS(REF(CCI3,1)-CCI3),LINETHICK0;
CCI4:=(TYP-MA(TYP,30))/(0.015*AVEDEV(TYP,30));
差值4:=ABS(REF(CCI4,1)-CCI4),LINETHICK0;
CCI5:=(TYP-MA(TYP,60))/(0.015*AVEDEV(TYP,60));
{以上通达信公式你们学会怎么用了吗,如果你还想了解更多更多通达信公式指标,欢迎及时关注中金指南网}

差值5:=ABS(REF(CCI5,1)-CCI5),LINETHICK0;
CCI:=CCI1+CCI2+CCI3+CCI4+CCI5;
AAA:=(3*C+H+L+O)/6;
VAR1:=(8*AAA+7*REF(AAA,1)+6*REF(AAA,2)+5*REF(AAA,3)+4*REF(AAA,4)+3*REF(AAA,5)+2*REF(AAA,6)+REF(AAA,8))/36;
VAR2:=(HHV(VAR1,5)+HHV(VAR1,10)+HHV(VAR1,20))/3;
VAR3:=(LLV(VAR1,5)+LLV(VAR1,10)+LLV(VAR1,20))/3;
VAR4:=(HHV(VAR2,5)+HHV(VAR2,10)+HHV(VAR2,20))/3;
VAR5:=(LLV(VAR3,5)+LLV(VAR3,10)+LLV(VAR3,20))/3;
VAR6:=(LLV(VAR1,2)+LLV(VAR1,4)+LLV(VAR1,6))/3;
短线:VAR1,COLORWHITE;
中线:VAR6,COLORYELLOW;
下跌:IF(VAR1=VAR6,VAR6, DRAWNULL),COLORGREEN;
TJ1:= CCI1>差值4;
立桩量:=FILTER(TJ1,0);
TJ2:=IF(BARSLAST(立桩量)=1 ,1,IF(BARSLAST(立桩量)=2 ,1,

IF(BARSLAST(立桩量)=3 ,1,0)));
成立1:=TJ2;
条件成立1:=FILTER(成立1,5);
TJ11:= CCI1<-差值4 ;
立桩量2:=FILTER(TJ11,0);
TJ22:=IF(BARSLAST(立桩量2)=1 AND CLOSE>REF(HIGH,1),1,

IF(BARSLAST(立桩量2)=2 AND CLOSE>REF(HIGH,2),1,

IF(BARSLAST(立桩量2)=3 AND CLOSE>REF(HIGH,3),1,0)));
成立2:=TJ22;
条件成立2:=FILTER(成立2,5);
TJ111:=(ABS(CCI1)>CCI AND ABS( 差值1)> ABS(差值5))

OR (VOL=HHV(VOL,10) AND VOL>2*REF(VOL,1) AND CLOSE>VAR1);
立桩量3:=FILTER(TJ111,5);
TJ222:=IF(BARSLAST(立桩量3)=1 AND CLOSE>REF(HIGH,1),1,IF(BARSLAST(立桩量3)=2 AND CLOSE>REF(HIGH,2),1,IF(BARSLAST(立桩量3)=3 AND CLOSE>REF(HIGH,3),1,0)));
突破3:=TJ222=1;
STICKLINE(CLOSE AND 下跌!= VAR6,REF(HIGH,BARSLAST(立桩量3)),

REF(HIGH,BARSLAST(立桩量3)),10,1),COLORCYAN;
STICKLINE(CLOSE AND 下跌!= VAR6,REF(LOW,BARSLAST(立桩量3)),

REF(LOW,BARSLAST(立桩量3)),10,1),COLORYELLOW;
TJ3:=IF(BARSLAST(立桩量3)=1 AND CLOSE>REF(LOW,1),1,IF(BARSLAST(立桩量3)=2 AND CLOSE>REF(LOW,2),1,IF(BARSLAST(立桩量3)=3 AND CLOSE>REF(LOW,3),1,0)));
三天法则:=TJ3=1;
成立:=三天法则 AND 突破3;
条件成立:=FILTER(成立,5);
TJ31:=(VOL=HHV(VOL,10) AND VOL>2*REF(VOL,1) AND CLOSE>VAR1);
TJ32:=FILTER(TJ31,1);
IF(条件成立 AND 下跌!= VAR6 AND AA30>=REF(AA30,1),H*1.03,DRAWNULL),CROSSDOT,LINETHICK6,COLORFF33FF;
IF(条件成立 AND 下跌!= VAR6 AND AA30>=REF(AA30,1),H*1.03,DRAWNULL),POINTDOT,LINETHICK4,COLOR00CCFF;
STICKLINE(C>=O,L,H,0,0),COLORRED;
STICKLINE(C<O,L,H,0,0),COLORFFFF00;
STICKLINE(C>O,C,O,3.2,0),COLORRED;
STICKLINE(1,C,O,2.8,0),COLOR454500;
STICKLINE(1,C,O,2,0),COLOR555500;
STICKLINE(1,C,O,1.5,0),COLOR656500;
STICKLINE(1,C,O,1,0),COLOR757500;
STICKLINE(1,C,O,0.5,0),COLOR858500;
STICKLINE(立桩量,C,O,2.8,0),COLOR000045;
STICKLINE(立桩量,C,O,2.8,0),COLOR000065;
STICKLINE(立桩量,C,O,2,0),COLOR000085;
STICKLINE(立桩量,C,O,1.5,0),COLOR0000A5;
STICKLINE(立桩量,C,O,1,0),COLOR0000C5;
STICKLINE(立桩量,C,O,0.5,0),COLOR0000E5;
DRAWICON(条件成立1,REF(HIGH,BARSLAST(立桩量3)),12);
DRAWICON(条件成立2,REF(LOW,BARSLAST(立桩量3)),11);

指标公式动态翻译

AA05赋值:收盘价的5日简单移动平均,COLOR0099CC
五日乖离率赋值:(收盘价-AA05)/AA05*100
BB05赋值:(AA05/1日前的AA05-1)*100的反正切*180/3.1416
速度5赋值:(AA05-1日前的AA05)/1日前的AA05的3日指数移动平均*100的3日[1日权重]移动平均
输出加速度5:(速度5-1日前的速度5)的3日指数移动平均,NODRAW
AA10赋值:收盘价的10日简单移动平均
AA20赋值:收盘价的20日简单移动平均
BB10赋值:(AA10/1日前的AA10-1)*100的反正切*180/3.1416
AA30赋值:收盘价的30日简单移动平均
三拾日乖离率赋值:(收盘价-AA30)/AA30*100
VAR11赋值:(AA20-AA30)>1日前的(AA20-AA30)AND AA20>1日前的AA20 AND AA30>1日前的AA30
VAR22赋值:(AA30-AA20)<1日前的(AA30-AA20) AND AA20<1日前的AA20 ANDAA30<1日前的AA30
BB30赋值:(AA30/1日前的AA30-1)*100的反正切*180/3.1416
强势狙击赋值:BB30>30ANDBB10>45ANDCROSS(BB05,60)的10日过滤
加仓赋值:统计5日中满足BB05上穿30的天数>=1ANDAA05>1日前的AA05AND三拾日乖离率>1日前的三拾日乖离率ANDAA10>1日前的AA10AND加速度5>1日前的加速度5AND速度5>1日前的速度5的10日过滤 
清仓赋值:统计5日中满足30上穿BB05的天数>=1AND(收盘价>AA30ORO>AA30)ANDAA05<1日前的AA05AND三拾日乖离率<1日前的三拾日乖离率ANDAA10<1日前的AA10的10日过滤
当满足条件加仓时,在最低价*0.99位置画23号图标
当满足条件清仓时,在最高价*1.01位置画15号图标
当满足条件强势狙击时,在最低价*0.99位置画13号图标
赋值: (最高价 + 最低价 + 收盘价)/3
CCI1赋值:(TYP-TYP的6日简单移动平均)/(0.015*TYP的6日平均绝对偏差)
差值1赋值:1日前的CCI1-CCI1的绝对值,线宽为0
CCI2赋值:(TYP-TYP的10日简单移动平均)/(0.015*TYP的10日平均绝对偏差)
差值2赋值:1日前的CCI2-CCI2的绝对值,线宽为0
CCI3赋值:(TYP-TYP的20日简单移动平均)/(0.015*TYP的20日平均绝对偏差)
差值3赋值:1日前的CCI3-CCI3的绝对值,线宽为0
CCI4赋值:(TYP-TYP的30日简单移动平均)/(0.015*TYP的30日平均绝对偏差)
差值4赋值:1日前的CCI4-CCI4的绝对值,线宽为0
CCI5赋值:(TYP-TYP的60日简单移动平均)/(0.015*TYP的60日平均绝对偏差)
差值5赋值:1日前的CCI5-CCI5的绝对值,线宽为0
CCI赋值:CCI1+CCI2+CCI3+CCI4+CCI5
AAA赋值:(3*收盘价+最高价+最低价+开盘价)/6
VAR1赋值:(8*AAA+7*1日前的AAA+6*2日前的AAA+5*3日前的AAA+4*4日前的AAA+3*5日前的AAA+2*6日前的AAA+8日前的AAA)/36
VAR2赋值:(5日内VAR1的最高值+10日内VAR1的最高值+20日内VAR1的最高值)/3
VAR3赋值:(5日内VAR1的最低值+10日内VAR1的最低值+20日内VAR1的最低值)/3
VAR4赋值:(5日内VAR2的最高值+10日内VAR2的最高值+20日内VAR2的最高值)/3
VAR5赋值:(5日内VAR3的最低值+10日内VAR3的最低值+20日内VAR3的最低值)/3
VAR6赋值:(2日内VAR1的最低值+4日内VAR1的最低值+6日内VAR1的最低值)/3
输出短线:VAR1,画白色
输出中线:VAR6,画黄色
输出下跌:如果VAR1=VAR6,返回VAR6,否则返回无效数,画绿色
TJ1赋值: CCI1>差值4
立桩量赋值:TJ1的历史过滤
TJ2赋值:如果上次立桩量距今天数=1,返回1,否则返回如果上次立桩量距今天数=2,返回1,否则返回如果上次立桩量距今天数=3,返回1,否则返回0
成立1赋值:TJ2
条件成立1赋值:成立1的5日过滤
TJ11赋值: CCI1<-差值4 
立桩量2赋值:TJ11的历史过滤
TJ22赋值:如果上次立桩量2距今天数=1ANDCLOSE>1日前的最高价,返回1,否则返回如果上次立桩量2距今天数=2ANDCLOSE>2日前的最高价,返回1,否则返回如果上次立桩量2距今天数=3ANDCLOSE>3日前的最高价,返回1,否则返回0
成立2赋值:TJ22
条件成立2赋值:成立2的5日过滤
TJ111赋值:(CCI1的绝对值>CCI AND 差值1的绝对值> 差值5的绝对值)OR (成交量(手)=10日内成交量(手)的最高值 AND 成交量(手)>2*1日前的成交量(手) AND 收盘价>VAR1)
立桩量3赋值:TJ111的5日过滤
TJ222赋值:如果上次立桩量3距今天数=1ANDCLOSE>1日前的最高价,返回1,否则返回如果上次立桩量3距今天数=2ANDCLOSE>2日前的最高价,返回1,否则返回如果上次立桩量3距今天数=3ANDCLOSE>3日前的最高价,返回1,否则返回0
突破3赋值:TJ222=1
当满足条件CLOSEAND下跌不等于VAR6时,在上次立桩量3距今天数日前的最高价和上次立桩量3距今天数日前的最高价位置之间画柱状线,宽度为10,1不为0则画空心柱.,画青色
当满足条件CLOSEAND下跌不等于VAR6时,在上次立桩量3距今天数日前的最低价和上次立桩量3距今天数日前的最低价位置之间画柱状线,宽度为10,1不为0则画空心柱.,画黄色
TJ3赋值:如果上次立桩量3距今天数=1ANDCLOSE>1日前的最低价,返回1,否则返回如果上次立桩量3距今天数=2ANDCLOSE>2日前的最低价,返回1,否则返回如果上次立桩量3距今天数=3ANDCLOSE>3日前的最低价,返回1,否则返回0
三天法则赋值:TJ3=1
成立赋值:三天法则 AND 突破3
条件成立赋值:成立的5日过滤
TJ31赋值:(成交量(手)=10日内成交量(手)的最高值 AND 成交量(手)>2*1日前的成交量(手) AND 收盘价>VAR1)
TJ32赋值:TJ31的1日过滤
如果条件成立AND下跌不等于VAR6ANDAA30>=1日前的AA30,返回最高价*1.03,否则返回无效数,CROSSDOT,线宽为6,COLORFF33FF
如果条件成立AND下跌不等于VAR6ANDAA30>=1日前的AA30,返回最高价*1.03,否则返回无效数,POINTDOT,线宽为4,COLOR00CCFF
当满足条件收盘价>=开盘价时,在最低价和最高价位置之间画柱状线,宽度为0,0不为0则画空心柱.,画红色
当满足条件收阴线时,在最低价和最高价位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLORFFFF00
当满足条件收阳线时,在收盘价和开盘价位置之间画柱状线,宽度为3.2,0不为0则画空心柱.,画红色
当满足条件1时,在收盘价和开盘价位置之间画柱状线,宽度为2.8,0不为0则画空心柱.,COLOR454500
当满足条件1时,在收盘价和开盘价位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLOR555500
当满足条件1时,在收盘价和开盘价位置之间画柱状线,宽度为1.5,0不为0则画空心柱.,COLOR656500
当满足条件1时,在收盘价和开盘价位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLOR757500
当满足条件1时,在收盘价和开盘价位置之间画柱状线,宽度为0.5,0不为0则画空心柱.,COLOR858500
当满足条件立桩量时,在收盘价和开盘价位置之间画柱状线,宽度为2.8,0不为0则画空心柱.,COLOR000045
当满足条件立桩量时,在收盘价和开盘价位置之间画柱状线,宽度为2.8,0不为0则画空心柱.,COLOR000065
当满足条件立桩量时,在收盘价和开盘价位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLOR000085
当满足条件立桩量时,在收盘价和开盘价位置之间画柱状线,宽度为1.5,0不为0则画空心柱.,COLOR0000A5
当满足条件立桩量时,在收盘价和开盘价位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLOR0000C5
当满足条件立桩量时,在收盘价和开盘价位置之间画柱状线,宽度为0.5,0不为0则画空心柱.,COLOR0000E5
当满足条件条件成立1时,在上次立桩量3距今天数日前的最高价位置画12号图标
当满足条件条件成立2时,在上次立桩量3距今天数日前的最低价位置画11号图标

全画线主图公式用法学会了吗,中金指南网提供更多优质的通达信、同花顺指标公式,欢迎持续关注中金指南网。

相关文章