通达信指标公式大全均线加角度选股公式

来源:中金指南网

公式指标用法

均线加角度选股公式指标,这是一款关联K线的主图指标公式,同时包含攻击线、主力攻击必杀进信号。当指标发出必杀进场信号时可跟随主力进场博弈。

公式指标案例

均线加角度选股公式
均线加角度选股公式

公式指标源码

{波峰}
TY:=H;
A1:=REF(TY,10)=HHV(TY,2*10+1); B1:=FILTER(A1,10); C1:=BACKSET(B1,10+1);
HD:=FILTER(C1,10);
A2:=REF(TY,10)=LLV(TY,2*10+1); B2:=FILTER(A2,10); C002:=BACKSET(B2,10+1);
LD:=FILTER(C002,10);
波峰:REF(H,BARSLAST(HD)),COLOR00808F,POINTDOT,LINETHICK4;
STICKLINE(H,波峰,波峰,8,0),COLOR00808F,LINETHICK4;
{彩色K线}
TYX3:=MA(REF(HHV((C+L+O+H)/4,30),1),3);
TYX4:=MA((C+L+O+H)/4,13);
TYX5:=EMA((C+L+O+H)/4,21);
{空心红}
STICKLINE(C<TYX5 AND C>O,H,L,0,0),COLORRED;
STICKLINE(C<TYX5 AND C>O,C,O,3,1),COLORRED;
{深绿}
STICKLINE(C<TYX5 AND C<O,H,L,0,0),COLOR007700;
STICKLINE(C<TYX5 AND C<O,C,O,3,0),COLOR005500;
STICKLINE(C<TYX5 AND C<O,C,O,2,0),COLOR006600;
STICKLINE(C<TYX5 AND C<O,C,O,1,0),COLOR007700;
{蓝}
STICKLINE(C>TYX5 AND C<O,H,L,0,0),COLORFFDD44;
STICKLINE(C>TYX5 AND C<O,C,O,3,0 ),COLORFF7700;
STICKLINE(C>TYX5 AND C<O,C,O,2,0 ),COLORFFAA22;
STICKLINE(C>TYX5 AND C<O,C,O,1 ,0 ),COLORFFDD44;
{黄}
STICKLINE(C>TYX5 AND C>O,H,L,0,0 ),COLOR00EEFF;
STICKLINE(C>TYX5 AND C>O,C,O,3,0 ),COLOR00AAFF;
STICKLINE(C>TYX5 AND C>O,C,O,2,0 ),COLOR00CCFF;
STICKLINE(C>TYX5 AND C>O,C,O,1,0 ),COLOR00EEFF;
{粉红}
STICKLINE(C>TYX4 AND C>O,H,L,0,0),COLORFF66AA;
STICKLINE(C>TYX4 AND C>O,C,O,3,0 ),COLORFF11FF;
STICKLINE(C>TYX4 AND C>O,C,O,2,0 ),COLORFF44FF;
STICKLINE(C>TYX4 AND C>O,C,O,1,0 ),COLORFF66FF;
{亮灰}
STICKLINE(C>TYX4 AND C<O,H,L,0,0),COLOR999999;
STICKLINE(C>TYX4 AND C<O,C,O,3,0),COLOR555555;
STICKLINE(C>TYX4 AND C<O,C,O,2,0),COLOR777777;
STICKLINE(C>TYX4 AND C<O,C,O,1,0),COLOR999999;
{深红}
STICKLINE(C>TYX3 AND C>O,H,L,0,0),COLOR0000DD;
STICKLINE(C>TYX3 AND C>O,C,O,3,0),COLOR000099;
STICKLINE(C>TYX3 AND C>O,C,O,2,0),COLOR0000BB;
STICKLINE(C>TYX3 AND C>O,C,O,1,0),COLOR0000DD;
{涨跌停K线}
STICKLINE((C-REF(C,1))*100/REF(C,1)>=(10-0.01*100/REF(C,1)),OPEN,CLOSE,1,0),COLORYELLOW;
STICKLINE((REF(C,1)-C)*100/REF(C,1)>=(10-0.01*100/REF(C,1)),OPEN,CLOSE,1,0),COLORWHITE;
{突破}
STICKLINE(REF(COUNT(C<TYX3,5)=5,1) AND C>TYX3 AND C>O,C,O,1,0),COLOR00CCFF;
STICKLINE(REF(COUNT(C<TYX3,5)=5,1) AND C>TYX3 AND C>O,C,O,1,0),COLOR00CCFF;
MA05:=MA(C,5);
MA5角度: ATAN((MA05/REF(MA05,1)-1)*100)*180/3.1416,NODRAW;
T01:=CONST(LLVBARS(LOW,10));
T1HIGH:=CONST(REF(HIGH,T01));
MM:=CONST(CURRBARSCOUNT);
T02:=CONST(BARSLAST(CURRBARSCOUNT>MM+T01 AND H>T1HIGH));
T2HIGH:=CONST(REF(HIGH,T02));
T03:=CONST(BARSLAST(CURRBARSCOUNT>MM+T02 AND HIGH>T2HIGH));
T3HIGH:=CONST(REF(HIGH,T03));
攻击线:DRAWLINE(CURRBARSCOUNT=T03+1, T3HIGH, ISLASTBAR, T3HIGH,1),LINETHICK3,COLOR8080FF;
DRAWTEXT(ISLASTBAR, T3HIGH, '必杀攻击线')LINETHICK2,COLORCYAN;
{趋势线}
A6A:=REF(HIGH,6)=HHV(HIGH,2*6+1);
B6A:=FILTER(A6A,6);
C6A:=BACKSET(B6A,6+1);
D6A:=FILTER(C6A,6);
A7A:=REF(LOW,6)=LLV(LOW,2*6+1);
B7A:=FILTER(A7A,6);
C7A:=BACKSET(B7A,6+1);
D7A:=FILTER(C7A,6);
E6A:=(REF(LLV(LOW,2*6),1)+REF(HHV(HIGH,2*6),1))/2;
E7A:=(HIGH+LOW)/2;
H6A:=(D6A AND NOT(D7A AND E6A>=E7A)) OR BARSTATUS=2 OR BARSCOUNT(CLOSE)=1;
H7A:=D6A AND NOT(D7A AND E6A>=E7A);
L6A:=D7A AND NOT(D6A AND E6A=E7A);
X6A:=REF(BARSLAST(H6A),1)+1;
F6A:=BACKSET(H6A AND COUNT(L6A,X6A)>0,LLVBARS(IF(L6A,LOW,10000),X6A));
G6A:=F6A>REF(F6A,1);
I6A:=BACKSET(G6A,2);
LD2A:=I6A>REF(I6A,1);
L7A:=LD2A OR BARSTATUS=2 OR BARSCOUNT(CLOSE)=1;
X7A:=REF(BARSLAST(L7A),1)+1;
F7A:=BACKSET(L7A AND COUNT(H7A,X7A)>0,HHVBARS(IF(H7A,HIGH,0),X7A));
G7A:=F7A>REF(F7A,1);
I7A:=BACKSET(G7A,2);
HD2A:=I7A>REF(I7A,1);
UU3A:=BACKSET(BARSTATUS=2,BARSLAST(LD2A)+1);
VV3A:=UU3A>REF(UU3A,1);
WW3A:=BACKSET(VV3A,REF(BARSLAST(LD2A),1)+2);
XX3A:=WW3A>REF(WW3A,1);
{下支撑线}
DRAWLINE(XX3A,L,VV3A,L,1),COLORCYAN,LINETHICK2;
UU4A:=BACKSET(BARSTATUS=2,BARSLAST(HD2A)+1);
VV4A:=UU4A>REF(UU4A,1);
WW4A:=BACKSET(VV4A,REF(BARSLAST(HD2A),1)+2);
XX4A:=WW4A>REF(WW4A,1);
{上支撑线}
DRAWLINE(XX4A,H,VV4A,H,1),COLOR8000F0,LINETHICK2;

公式指标动态翻译

TY赋值:最高价
A1赋值:10日前的TY=2*10+1日内TY的最高值
B1赋值:A1的10日过滤
C1赋值:若B1则将最近10+1周期置为1
HD赋值:C1的10日过滤
A2赋值:10日前的TY=2*10+1日内TY的最低值
B2赋值:A2的10日过滤
C002赋值:若B2则将最近10+1周期置为1
LD赋值:C002的10日过滤
输出
波峰:上次HD距今天数日前的最高价,COLOR00808F,POINTDOT,线宽为4
当满足条件最高价时,在波峰和波峰位置之间画柱状线,宽度为8,0不为0则画空心柱.,COLOR00808F,线宽为4
TYX3赋值:1日前的30日内(收盘价+最低价+开盘价+最高价)/4的最高值的3日简单移动平均
TYX4赋值:(收盘价+最低价+开盘价+最高价)/4的13日简单移动平均
TYX5赋值:(收盘价+最低价+开盘价+最高价)/4的21日指数移动平均
当满足条件收盘价<TYX5ANDC>开盘价时,在最高价和最低价位置之间画柱状线,宽度为0,0不为0则画空心柱.,画红色
当满足条件收盘价<TYX5ANDC>开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为3,1不为0则画空心柱.,画红色
当满足条件收盘价<TYX5ANDC<开盘价时,在最高价和最低价位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLOR007700
当满足条件收盘价<TYX5ANDC<开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR005500
当满足条件收盘价<TYX5ANDC<开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLOR006600
当满足条件收盘价<TYX5ANDC<开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLOR007700
当满足条件收盘价>TYX5ANDC<开盘价时,在最高价和最低价位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLORFFDD44
当满足条件收盘价>TYX5ANDC<开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLORFF7700
当满足条件收盘价>TYX5ANDC<开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLORFFAA22
当满足条件收盘价>TYX5ANDC<开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLORFFDD44
当满足条件收盘价>TYX5ANDC>开盘价时,在最高价和最低价位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLOR00EEFF
当满足条件收盘价>TYX5ANDC>开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR00AAFF
当满足条件收盘价>TYX5ANDC>开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLOR00CCFF
当满足条件收盘价>TYX5ANDC>开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLOR00EEFF
当满足条件收盘价>TYX4ANDC>开盘价时,在最高价和最低价位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLORFF66AA
当满足条件收盘价>TYX4ANDC>开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLORFF11FF
当满足条件收盘价>TYX4ANDC>开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLORFF44FF
当满足条件收盘价>TYX4ANDC>开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLORFF66FF
当满足条件收盘价>TYX4ANDC<开盘价时,在最高价和最低价位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLOR999999
当满足条件收盘价>TYX4ANDC<开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR555555
当满足条件收盘价>TYX4ANDC<开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLOR777777
当满足条件收盘价>TYX4ANDC<开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLOR999999
当满足条件收盘价>TYX3ANDC>开盘价时,在最高价和最低价位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLOR0000DD
当满足条件收盘价>TYX3ANDC>开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR000099
当满足条件收盘价>TYX3ANDC>开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLOR0000BB
当满足条件收盘价>TYX3ANDC>开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLOR0000DD
当满足条件(收盘价-1日前的收盘价)*100/1日前的收盘价>=(10-0.01*100/1日前的收盘价)时,在开盘价和收盘价位置之间画柱状线,宽度为1,0不为0则画空心柱.,画黄色
当满足条件(1日前的收盘价-收盘价)*100/1日前的收盘价>=(10-0.01*100/1日前的收盘价)时,在开盘价和收盘价位置之间画柱状线,宽度为1,0不为0则画空心柱.,画白色
当满足条件1日前的统计5日中满足收盘价<TYX3的天数=5ANDC>TYX3ANDC>开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLOR00CCFF
当满足条件1日前的统计5日中满足收盘价<TYX3的天数=5ANDC>TYX3ANDC>开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLOR00CCFF
MA05赋值:收盘价的5日简单移动平均
输出
MA5角度: (MA05/1日前的MA05-1)*100的反正切*180/3.1416,NODRAW
T01赋值:10日内最低价距今天数的最后一日取值设为常数
T1HIGH赋值:T01日前的最高价的最后一日取值设为常数
MM赋值:到最后交易的周期的最后一日取值设为常数
T02赋值:上次到最后交易的周期>MM+T01ANDH>T1HIGH距今天数的最后一日取值设为常数
T2HIGH赋值:T02日前的最高价的最后一日取值设为常数
T03赋值:上次到最后交易的周期>MM+T02ANDHIGH>T2HIGH距今天数的最后一日取值设为常数
T3HIGH赋值:T03日前的最高价的最后一日取值设为常数
输出
攻击线:当满足条件到最后交易的周期=T03+1时,在T3HIGH位置画直线起点,当满足条件是否最后一个周期时,在T3HIGH位置画直线终点,1表示是否延长.,线宽为3,COLOR8080FF

当满足条件是否最后一个周期时,在T3HIGH位置书写文字线宽为2,画青色
A6A赋值:6日前的最高价=2*6+1日内最高价的最高值
B6A赋值:A6A的6日过滤
C6A赋值:若B6A则将最近6+1周期置为1
D6A赋值:C6A的6日过滤
A7A赋值:6日前的最低价=2*6+1日内最低价的最低值
B7A赋值:A7A的6日过滤
C7A赋值:若B7A则将最近6+1周期置为1
D7A赋值:C7A的6日过滤
E6A赋值:(1日前的2*6日内最低价的最低值+1日前的2*6日内最高价的最高值)/2
E7A赋值:(最高价+最低价)/2
H6A赋值:(D6A AND 取反) OR 数据位置状态=2 OR 收盘价的有效数据周期数=1
H7A赋值:D6A AND 取反
L6A赋值:D7A AND 取反
X6A赋值:1日前的上次H6A距今天数+1
F6A赋值:若H6AANDCOUNT(L6A,X6A)>0则将最近X6A日内如果L6A,返回最低价,否则返回10000距今天数周期置为1
G6A赋值:F6A>1日前的F6A
I6A赋值:若G6A则将最近2周期置为1
LD2A赋值:I6A>1日前的I6A
L7A赋值:LD2A OR 数据位置状态=2 OR 收盘价的有效数据周期数=1
X7A赋值:1日前的上次L7A距今天数+1
F7A赋值:若L7AANDCOUNT(H7A,X7A)>0则将最近X7A日内如果H7A,返回最高价,否则返回0距今天数周期置为1
G7A赋值:F7A>1日前的F7A
I7A赋值:若G7A则将最近2周期置为1
HD2A赋值:I7A>1日前的I7A
UU3A赋值:若数据位置状态=2则将最近上次LD2A距今天数+1周期置为1
VV3A赋值:UU3A>1日前的UU3A
WW3A赋值:若VV3A则将最近1日前的上次LD2A距今天数+2周期置为1
XX3A赋值:WW3A>1日前的WW3A

当满足条件XX3A时,在最低价位置画直线起点,当满足条件VV3A时,在最低价位置画直线终点,1表示是否延长.,画青色,线宽为2
UU4A赋值:若数据位置状态=2则将最近上次HD2A距今天数+1周期置为1
VV4A赋值:UU4A>1日前的UU4A
WW4A赋值:若VV4A则将最近1日前的上次HD2A距今天数+2周期置为1
XX4A赋值:WW4A>1日前的WW4A

当满足条件XX4A时,在最高价位置画直线起点,当满足条件VV4A时,在最高价位置画直线终点,1表示是否延长.,COLOR8000F0,线宽为2

以上关于通达信主图均线加角度选股公式指标使用方法学会了吗,如果你还想了解更多更多通达信公式指标,欢迎关注中金指南。

相关文章