通达信dmi买卖点指标公式及用法

来源:中金指南网

指标公式用法

dmi买卖点指标公式修改版,黄色顶部线、底部线紫色、中部线浅黄色、股价趋势线红色,底部警戒线军绿色,红线上穿紫线和底部警戒线多头行情,红线高位向下死叉看空。

指标公式案例

dmi,买卖点

dmi买卖点指标公式

指标公式源码

TRR:=EMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),14);
HD :=HIGH-REF(HIGH,1);
LD :=REF(LOW,1)-LOW;
DMP:=EMA(IF(HD>0 OR HD>LD,HD,0),14);
DMM:=EMA(IF(LD>0 OR LD>HD,LD,0),14);
PDI: DMP*100/TRR,COLORWHITE;
MDI: DMM*100/TRR,COLORYELLOW;
趋势线:MA(EMA(PDI,2),10),COLORRED,LINETHICK2;
STICKLINE(PDI>趋势线,趋势线,PDI,0.05,0),COLORMAGENTA;
STICKLINE(PDI>MDI,PDI,趋势线,0.1,0),COLORRED;
STICKLINE(PDI>MDI,MDI,趋势线,0.1,0),COLORLIRED;
STICKLINE(PDI<趋势线,趋势线,PDI,0.05,0),COLORFF8000;
STICKLINE(PDI<MDI,PDI,MDI,0.1,0),COLORBLUE;
ADX: EMA(ABS(MDI-PDI)/(MDI+PDI)*100,6),COLORGREEN;
ADXR:EMA(ADX,6),COLORMAGENTA;

指标公式动态翻译

TRR赋值:最高价-最低价和最高价-1日前的收盘价的绝对值的较大值和1日前的收盘价-最低价的绝对值的较大值的14日指数移动平均
赋值:最高价-1日前的最高价
赋值:1日前的最低价-最低价
DMP赋值:如果HD>0ORHD>LD,返回HD,否则返回0的14日指数移动平均
DMM赋值:如果LD>0ORLD>HD,返回LD,否则返回0的14日指数移动平均
输出PDI: DMP*100/TRR,画白色
输出MDI: DMM*100/TRR,画黄色
输出趋势线:PDI的2日指数移动平均的10日简单移动平均,画红色,线宽为2
当满足条件PDI>趋势线时,在趋势线和PDI位置之间画柱状线,宽度为0.05,0不为0则画空心柱.,画洋红色
当满足条件PDI>MDI时,在PDI和趋势线位置之间画柱状线,宽度为0.1,0不为0则画空心柱.,画红色
当满足条件PDI>MDI时,在MDI和趋势线位置之间画柱状线,宽度为0.1,0不为0则画空心柱.,画淡红色
当满足条件PDI<趋势线时,在趋势线和PDI位置之间画柱状线,宽度为0.05,0不为0则画空心柱.,COLORFF8000
当满足条件PDI<MDI时,在PDI和MDI位置之间画柱状线,宽度为0.1,0不为0则画空心柱.,画蓝色
输出ADX: MDI-PDI的绝对值/(MDI+PDI)*100的6日指数移动平均,画绿色
输出ADXR:ADX的6日指数移动平均,画洋红色

dmi买卖点指标公式用法学会了吗,中金指南网提供更多优质的通达信、同花顺指标公式,欢迎持续关注中金指南网。

相关文章