主力波段进场指标公式解释_通达信

来源:中金指南网

指标公式用法

主力波段进场指标公式,上图中粉色柱是主力吸货提示,柱子越长主力参考力度越大,黄色黄金线上穿稳定线和彩带线形成金叉积极看多,后市上涨概率较大。

指标公式案例

主力,波段,主力进场

指标公式源码

顶高:=100.00,COLOR111111;
中线:50.00,COLOR111111;
底线:0.00,COLOR111111;
MB03:=MA(C,3);
MB10:=MA(C,10);
MB1:=EMA(CLOSE,12)-EMA(CLOSE,26);
MB2:=EMA(MB1,9);
MB3:=(MB1-MB2)*2;
柱线:=MB3;
MAR1:=((C-LLV(L,55))/(HHV(H,55)-LLV(L,55)))*100;
MAR2:=SMA(MAR1,13,8);
日价线:=CEILING(SMA(MAR2,13,8)),COLORRED,LINETHICK2;
MAR10:=EMA(日价线,15),COLORGREEN;
密集:(MB1>MB2 AND MB03>MB10)*100,COLORFFBB00,LINETHICK1;
DRAWBAND(顶高,RGB(0,65,45),密集,RGB(0,65,255));
DRAWBAND(底线,RGB(35,0,0),密集,RGB(85,0,0));
VAR1:=REF(LOW,1);
VAR2:=SMA(ABS(LOW-VAR1),3,1)/SMA(MAX(LOW-VAR1,0),3,1)*100;
VAR3:=EMA(IF(CLOSE*1.2,VAR2*5,VAR2/10),3);
VAR4:=LLV(LOW,38);
VAR5:=HHV(VAR3,38);
VAR6:=IF(LLV(LOW,90),1,0);
VAR7:=EMA(IF(LOW<=VAR4,(VAR3+VAR5*2)/2,0),3)/618*VAR6;
VAR8:=((C-LLV(L,55))/(HHV(H,55)-LLV(L,55)))*100;
VAR9:=SMA(VAR8,13,8);
主力吸货:VAR7,COLOR004000;
吸筹1:STICKLINE(VAR7,0,VAR7,3,0),COLOR0000FF;
吸筹2:STICKLINE(VAR7,0,VAR7,3,0),COLOR6600FF;
吸筹3:STICKLINE(VAR7,0,VAR7,3,0),COLORBB00FF;
吸筹4:STICKLINE(VAR7,0,VAR7,3,0),COLORFF00FF;
吸筹5:STICKLINE(VAR7,0,VAR7,2,0),COLORFF33FF;
吸筹6:STICKLINE(VAR7,0,VAR7,1,0),COLORFF66FF;
吸筹7:STICKLINE(VAR7,0,VAR7,0,0),COLORFF99FF;
日价:=CEILING(SMA(VAR9,13,8)),COLORRED,LINETHICK2;
中位线:50.00,COLOR9900FF;
日趋势:=日价线,COLOR66EEEE,LINETHICK2;
稳定线:MAR10,COLORFF00FF,LINETHICK1;
稳定鉴:EMA(MAR10,6),COLOR555555;
DRAWBAND(稳定线,RGB(255,0,128),稳定鉴,RGB(0,200,200));
上逃线:90.00,COLOR666666,DOTLINE;
设底:=LLV(日趋势,30);
底撑:REF(设底,1),COLORBLUE,LINETHICK2;
日趋黄金线:日趋势,COLOR66EEEE,LINETHICK2;
日趋虚线:EMA(日趋黄金线,5),COLOR999999,DOTLINE;
金叉:CROSS(日趋黄金线,底撑),NODRAW,COLORYELLOW;
STICKLINE(金叉,100,70,2,0)COLORYELLOW;
银叉:CROSS(日趋黄金线,稳定线),NODRAW,COLORWHITE;
STICKLINE(银叉,100,80,2,0)COLORWHITE;

指标公式动态翻译

顶高赋值:100.00,COLOR111111
输出中线:50.00,COLOR111111
输出底线:0.00,COLOR111111
MB03赋值:收盘价的3日简单移动平均
MB10赋值:收盘价的10日简单移动平均
MB1赋值:收盘价的12日指数移动平均-收盘价的26日指数移动平均
MB2赋值:MB1的9日指数移动平均
MB3赋值:(MB1-MB2)*2
柱线赋值:MB3
MAR1赋值:((收盘价-55日内最低价的最低值)/(55日内最高价的最高值-55日内最低价的最低值))*100
MAR2赋值:MAR1的13日[8日权重]移动平均
日价线赋值:MAR2的13日[8日权重]移动平均的向上舍入,画红色,线宽为2
MAR10赋值:日价线的15日指数移动平均,画绿色
输出密集:(MB1>MB2 AND MB03>MB10)*100,COLORFFBB00,线宽为1
画带状线
画带状线
VAR1赋值:1日前的最低价
VAR2赋值:最低价-VAR1的绝对值的3日[1日权重]移动平均/最低价-VAR1和0的较大值的3日[1日权重]移动平均*100
VAR3赋值:如果收盘价*1.2,返回VAR2*5,否则返回VAR2/10的3日指数移动平均
VAR4赋值:38日内最低价的最低值
VAR5赋值:38日内VAR3的最高值
VAR6赋值:如果90日内最低价的最低值,返回1,否则返回0
VAR7赋值:如果最低价<=VAR4,返回(VAR3+VAR5*2)/2,否则返回0的3日指数移动平均/618*VAR6
VAR8赋值:((收盘价-55日内最低价的最低值)/(55日内最高价的最高值-55日内最低价的最低值))*100
VAR9赋值:VAR8的13日[8日权重]移动平均
输出主力吸货:VAR7,COLOR004000
输出吸筹1:当满足条件VAR7时,在0和VAR7位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR0000FF
输出吸筹2:当满足条件VAR7时,在0和VAR7位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR6600FF
输出吸筹3:当满足条件VAR7时,在0和VAR7位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLORBB00FF
输出吸筹4:当满足条件VAR7时,在0和VAR7位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLORFF00FF
输出吸筹5:当满足条件VAR7时,在0和VAR7位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLORFF33FF
输出吸筹6:当满足条件VAR7时,在0和VAR7位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLORFF66FF
输出吸筹7:当满足条件VAR7时,在0和VAR7位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLORFF99FF
日价赋值:VAR9的13日[8日权重]移动平均的向上舍入,画红色,线宽为2
输出中位线:50.00,COLOR9900FF
日趋势赋值:日价线,COLOR66EEEE,线宽为2
输出稳定线:MAR10,COLORFF00FF,线宽为1
输出稳定鉴:MAR10的6日指数移动平均,COLOR555555
画带状线
输出上逃线:90.00,COLOR666666,DOTLINE
设底赋值:30日内日趋势的最低值
输出底撑:1日前的设底,画蓝色,线宽为2
输出日趋黄金线:日趋势,COLOR66EEEE,线宽为2
输出日趋虚线:日趋黄金线的5日指数移动平均,COLOR999999,DOTLINE
输出金叉:日趋黄金线上穿底撑,NODRAW,画黄色
当满足条件金叉时,在100和70位置之间画柱状线,宽度为2,0不为0则画空心柱.画黄色
输出银叉:日趋黄金线上穿稳定线,NODRAW,画白色
当满足条件银叉时,在100和80位置之间画柱状线,宽度为2,0不为0则画空心柱.画白色
 

主力波段进场指标公式用法学会了吗,中金指南网提供更多优质的通达信、同花顺指标公式,欢迎持续关注中金指南网。

相关文章