通达信主力资金进场趋势波段买点指标公式怎么看?

来源:中金指南网

指标公式用法

主力资金进场指标,指标有波段操作提示,趋势分析提示,以及主资金进场提示,在上图中白线上穿黄线金叉买点,同时提示大红柱子则是加仓提示。

指标公式案例

主力资金,主力进场,趋势,波段

指标公式源码

AA:=LLV(LOW,34);
BB:=HHV(HIGH,30);
DD:=(EMA(((CLOSE-AA)/(BB-AA))*(4),4))*(25);
谷:=(((DD-LLV(DD,21))/(HHV(DD,21)-LLV(DD,21)))*(4))*(25);
VAR1:=(CLOSE-LLV(LOW,36))/(HHV(HIGH,36)-LLV(LOW,36))*100;
VAR2:=SMA(VAR1,3,1);
VAR3:=SMA(VAR2,3,1);
VAR4:=SMA(VAR3,3,1);
波: VAR3,COLORWHITE;
段: VAR4,COLORYELLOW;
VAR6:=CROSS(VAR3,VAR4) AND VAR3<20;
DRAWTEXT(FILTER(VAR6,10)=1,40,'买'),LINETHICK1,COLOR00AAFF;
STICKLINE(FILTER(VAR6,10)=1,0,90,1,0),COLORRED;
VAR7:=CROSS(VAR4,VAR3) AND VAR3>80;
STICKLINE(FILTER(VAR7,5)=1,0,90,1,0),COLORGREEN ;
DRAWTEXT(FILTER(VAR7,5)=1,70,'卖'),LINETHICK1,COLORFFCC66;
趋势:3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1),LINETHICK0,COLORWHITE;
VAR8:=CROSS(VAR2,VAR3) AND VAR3>80 AND VAR3>VAR4;
VAR9:=CROSS(趋势,VAR2) AND 趋势<20 AND 趋势<段;
分批卖出:STICKLINE(VAR8,50,90,1,0),COLOR008360,LINETHICK3;
分批买入:STICKLINE(VAR9,40,0,1,0),COLOR000080,LINETHICK3;
90,COLORGREEN ;
0,COLORYELLOW ;
VAR01:=EMA((CLOSE-LLV(LOW,25))/(HHV(HIGH,25)-LLV(LOW,25))*100,5);
VAR02:=(HHV(HIGH,25)-LLV(LOW,25))/EMA((CLOSE-LLV(LOW,25)),5);
VAR03:=CROSS(VAR02,VAR01);
VAR04:=REF(VAR02,2)<REF(VAR02,1) AND VAR02<REF(VAR02,1);
VAR05:=COUNT(VAR03,7)>0 AND VAR04;
VAR06:=REF((LOW+OPEN+CLOSE+HIGH)/4,1);
VAR07:=SMA(ABS(LOW-VAR06),13,1)/SMA(MAX(LOW-VAR06,0),10,1);
VAR08:=EMA(VAR07,10);
VAR09:=EMA(C,5);
VAR10:=LLV(LOW,33);
VAR11:=EMA(IF(LOW<=VAR10,VAR09,0),3)*40;
VAR12:=IF(VAR11>100,VAR11*0.312,VAR11);
资金进场:VAR02,COLORRED;
BAR1:=REF(LOW,1);
BAR2:=SMA(ABS(LOW-BAR1),13,1)/SMA(MAX(LOW-BAR1,0),13,1)*4;
BAR3:=EMA(BAR2,13);
BAR4:=LLV(LOW,34);
BAR5:=EMA(IF(LOW<=BAR4,BAR3,0),3);
BAR6:=100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
BAR7:=100-3*SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
BAR8:=BAR6<REF(BAR7,1) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);
散户:STICKLINE(BAR5>REF(BAR5,1),0,BAR5,0.5,0),COLORGREEN,LINETHICK1;
STICKLINE(BAR8 AND COUNT(BAR8,30)=1,0,18,0.5,0),COLORBLUE,LINETHICK3;
STICKLINE(BAR8 AND COUNT(BAR8,30)=1,18,36,0.5,0),COLORFF7700,LINETHICK3;
STICKLINE(BAR8 AND COUNT(BAR8,30)=1,36,60,1,0),COLORYELLOW;
DRAWTEXT(BAR8 AND COUNT(BAR8,30)=1,90,'主力进场★'),COLORYELLOW;
RE:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;
R12:=(HIGH+LOW+CLOSE)/3;
R13:=(R12-MA(R12,14))/(0.015*AVEDEV(R12,14));
R14:=(R12-MA(R12,70))/(0.015*AVEDEV(R12,70));
R15:=IF(R13>=150 AND R13<200 AND R14>=150 AND R14<200,10,0);
R16:=IF(R13<=-150 AND R13>-200 AND R14<=-150 AND R14>-200,-10,R15);
R17:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;
R18:=100-ABS(R17);
R19:=IF(R18<90,R18,100);
R1A:=IF(RE>0,RE,0);
R1B:=IF(R14>=200 AND R13>=150,15,IF(R14<=-200 AND R13<=-150,-15,R16))+60;
R1C:=R1A>48 AND R1B>60 AND R19<100;
DRAWTEXT(R1C AND COUNT(R1C,25)=1,80,'分批出货'),LINETHICK1,COLORFFCC66;
STICKLINE(R1C AND COUNT(R1C,25)=1,90,60,0.5,0),COLORFFCC66;

指标公式动态翻译

AA赋值:34日内最低价的最低值
BB赋值:30日内最高价的最高值
DD赋值:(((收盘价-AA)/(BB-AA))*(4)的4日指数移动平均)*(25)
谷赋值:(((DD-21日内DD的最低值)/(21日内DD的最高值-21日内DD的最低值))*(4))*(25)
VAR1赋值:(收盘价-36日内最低价的最低值)/(36日内最高价的最高值-36日内最低价的最低值)*100
VAR2赋值:VAR1的3日[1日权重]移动平均
VAR3赋值:VAR2的3日[1日权重]移动平均
VAR4赋值:VAR3的3日[1日权重]移动平均
输出波: VAR3,画白色
输出段: VAR4,画黄色
VAR6赋值:VAR3上穿VAR4 AND VAR3<20
当满足条件VAR6的10日过滤=1时,在40位置书写文字,线宽为1,COLOR00AAFF
当满足条件VAR6的10日过滤=1时,在0和90位置之间画柱状线,宽度为1,0不为0则画空心柱.,画红色
VAR7赋值:VAR4上穿VAR3 AND VAR3>80
当满足条件VAR7的5日过滤=1时,在0和90位置之间画柱状线,宽度为1,0不为0则画空心柱.,画绿色 
当满足条件VAR7的5日过滤=1时,在70位置书写文字,线宽为1,COLORFFCC66
输出趋势:3*(收盘价-27日内最低价的最低值)/(27日内最高价的最高值-27日内最低价的最低值)*100的5日[1日权重]移动平均-2*(收盘价-27日内最低价的最低值)/(27日内最高价的最高值-27日内最低价的最低值)*100的5日[1日权重]移动平均的3日[1日权重]移动平均,线宽为0,画白色
VAR8赋值:VAR2上穿VAR3 AND VAR3>80 AND VAR3>VAR4
VAR9赋值:趋势上穿VAR2 AND 趋势<20 AND 趋势<段
输出分批卖出:当满足条件VAR8时,在50和90位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLOR008360,线宽为3
输出分批买入:当满足条件VAR9时,在40和0位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLOR000080,线宽为3
90,画绿色 
0,画黄色 
VAR01赋值:(收盘价-25日内最低价的最低值)/(25日内最高价的最高值-25日内最低价的最低值)*100的5日指数移动平均
VAR02赋值:(25日内最高价的最高值-25日内最低价的最低值)/(收盘价-25日内最低价的最低值)的5日指数移动平均
VAR03赋值:VAR02上穿VAR01
VAR04赋值:2日前的VAR02<1日前的VAR02 AND VAR02<1日前的VAR02
VAR05赋值:统计7日中满足VAR03的天数>0 AND VAR04
VAR06赋值:1日前的(最低价+开盘价+收盘价+最高价)/4
VAR07赋值:最低价-VAR06的绝对值的13日[1日权重]移动平均/最低价-VAR06和0的较大值的10日[1日权重]移动平均
VAR08赋值:VAR07的10日指数移动平均
VAR09赋值:收盘价的5日指数移动平均
VAR10赋值:33日内最低价的最低值
VAR11赋值:如果最低价<=VAR10,返回VAR09,否则返回0的3日指数移动平均*40
VAR12赋值:如果VAR11>100,返回VAR11*0.312,否则返回VAR11
输出资金进场:VAR02,画红色
BAR1赋值:1日前的最低价
BAR2赋值:最低价-BAR1的绝对值的13日[1日权重]移动平均/最低价-BAR1和0的较大值的13日[1日权重]移动平均*4
BAR3赋值:BAR2的13日指数移动平均
BAR4赋值:34日内最低价的最低值
BAR5赋值:如果最低价<=BAR4,返回BAR3,否则返回0的3日指数移动平均
BAR6赋值:100-3*(收盘价-75日内最低价的最低值)/(75日内最高价的最高值-75日内最低价的最低值)*100的20日[1日权重]移动平均+2*(收盘价-75日内最低价的最低值)/(75日内最高价的最高值-75日内最低价的最低值)*100的20日[1日权重]移动平均的15日[1日权重]移动平均
BAR7赋值:100-3*(开盘价-75日内最低价的最低值)/(75日内最高价的最高值-75日内最低价的最低值)*100的20日[1日权重]移动平均+2*(开盘价-75日内最低价的最低值)/(75日内最高价的最高值-75日内最低价的最低值)*100的20日[1日权重]移动平均的15日[1日权重]移动平均
BAR8赋值:BAR6<1日前的BAR7 AND 成交量(手)>1日前的成交量(手) AND 收盘价>1日前的收盘价
输出散户:当满足条件BAR5>1日前的BAR5时,在0和BAR5位置之间画柱状线,宽度为0.5,0不为0则画空心柱.,画绿色,线宽为1
当满足条件BAR8ANDCOUNT(BAR8,30)=1时,在0和18位置之间画柱状线,宽度为0.5,0不为0则画空心柱.,画蓝色,线宽为3
当满足条件BAR8ANDCOUNT(BAR8,30)=1时,在18和36位置之间画柱状线,宽度为0.5,0不为0则画空心柱.,COLORFF7700,线宽为3
当满足条件BAR8ANDCOUNT(BAR8,30)=1时,在36和60位置之间画柱状线,宽度为1,0不为0则画空心柱.,画黄色
当满足条件BAR8ANDCOUNT(BAR8,30)=1时,在90位置书写文字,画黄色
RE赋值:100*(收盘价-34日内收盘价的最低值)/(34日内最高价的最高值-34日内最低价的最低值)的5日简单移动平均-20
R12赋值:(最高价+最低价+收盘价)/3
R13赋值:(R12-R12的14日简单移动平均)/(0.015*R12的14日平均绝对偏差)
R14赋值:(R12-R12的70日简单移动平均)/(0.015*R12的70日平均绝对偏差)
R15赋值:如果R13>=150ANDR13<200ANDR14>=150ANDR14<200,返回10,否则返回0
R16赋值:如果R13<=-150ANDR13>-200ANDR14<=-150ANDR14>-200,返回-10,否则返回R15
R17赋值:(收盘价-收盘价的13日简单移动平均)/收盘价的13日简单移动平均*100
R18赋值:100-R17的绝对值
R19赋值:如果R18<90,返回R18,否则返回100
R1A赋值:如果RE>0,返回RE,否则返回0
R1B赋值:如果R14>=200ANDR13>=150,返回15,否则返回如果R14<=-200ANDR13<=-150,返回-15,否则返回R16+60
R1C赋值:R1A>48 AND R1B>60 AND R19<100
当满足条件R1CANDCOUNT(R1C,25)=1时,在80位置书写文字,线宽为1,COLORFFCC66
当满足条件R1CANDCOUNT(R1C,25)=1时,在90和60位置之间画柱状线,宽度为0.5,0不为0则画空心柱.,COLORFFCC66
 

主力资金进场趋势波段买点指标公式用法学会了吗,中金指南网提供更多优质的通达信、同花顺指标公式,欢迎持续关注中金指南网。

相关文章