通达信多空能量妖股转世加仓指标公式怎么看?

来源:中金指南网

指标公式用法

多空能量妖股转世加仓指标公式使用中一定要注意提示小心或必卖绝卖这是卖出信号,一定要注意风险,当低位提示加仓信号,红线多方能量上穿绿线空方能量金叉,说明多头占据优抛,空头衰竭,可积极加仓。

指标公式案例

多空,能量,妖股,加仓

指标公式源码

多方能量:7*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*30,4,1)

-3*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*30,4,1),3,1)

-SMA(SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*30,4,1)

,3,1),2,1),LINETHICK1,COLORRED;
空方能量:EMA(MA(多方能量,5),7),LINETHICK1,COLORGREEN;
{STICKLINE(空方能量<=多方能量,空方能量,多方能量,2,1),COLOR000099;
STICKLINE(空方能量>多方能量,空方能量,多方能量,2,1),COLORGREEN;
STICKLINE(多方能量>80 AND 多方能量>=空方能量,多方能量,80,1,0),COLORYELLOW;
STICKLINE(空方能量<15 AND 空方能量<=多方能量,空方能量,15,1,0),COLORBLUE;}

50,COLORRED;
60,CIRCLEDOT;
20,CIRCLEDOT;
8,CIRCLEDOT;
0;100;
VAR1:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*50;
AA: (EMA(VAR1,3))*2;
BB:MA(AA,3);
DRAWBAND(AA,RGB(150,0,150),BB,RGB(150,150,150));
STICKLINE(AA>=BB,53,47,4,0),COLOREE82EE;
STICKLINE(AA<BB,53,47,4,1),COLORB3EE3A;
STICKLINE(CROSS(AA,20),58,42,2,0),COLORB23AEE;
VAR2:8,COLORGREEN,LINETHICK0;
IF(CROSS(AA,VAR2),40,0),STICK,LINETHICK2;
DRAWICON(CROSS(AA,VAR2),40,13);
{淘金牛妖}

短期:=100*(C-LLV(L,5))/(HHV(C,5)-LLV(L,5)),;
中期:=100*(C-LLV(L,10))/(HHV(C,10)-LLV(L,10)),;
中长期:=100*(C-LLV(L,20))/(HHV(C,20)-LLV(L,20)),;
长期:=100*(C-LLV(L,30))/(HHV(C,30)-LLV(L,30)),;
强势线:80,DOTLINE;
分水岭:50,DOTLINE;
弱势线:20,DOTLINE;
DRAWTEXT(CROSS(中期,80) AND REF(中期,1)<80 AND MA(C,5)>REF(MA(C,5),1) AND 多方能量>空方能量,中期+2,'买');
DRAWTEXT(CROSS(长期,80) AND REF(长期,1)<80 AND MA(C,5)>REF(MA(C,5),1) AND 多方能量>空方能量,中期,'稳升');
DRAWTEXT(CROSS(80,长期) AND CROSS(80,中长期) AND CROSS(80,中期) AND REF(长期,1)>80

AND REF(中期,1)>80 AND REF(中长期,1)>80 AND 空方能量>多方能量,长期,'绝卖'),COLORGREEN;
DRAWTEXT(CROSS(80,短期) AND REF(短期,1)>80 AND 多方能量>空方能量,长期+2,'调'),COLORGREEN;
DRAWTEXT(CROSS(80,长期) AND REF(长期,1)>80 AND 空方能量>多方能量,长期+4,'必卖'),COLORGREEN;
DRAWTEXT(CROSS(80,短期) AND REF(短期,1)>80 AND 空方能量>多方能量,短期+2,'卖'),COLORGREEN;
DRAWICON(CROSS(多方能量,空方能量) AND REF(多方能量,1)<REF(空方能量,1),多方能量,34);
DRAWICON(CROSS(空方能量,多方能量) AND REF(多方能量,1)>REF(空方能量,1),空方能量,35);
能量走势:(多方能量-空方能量)+50,LINETHICK2,COLORYELLOW;
DRAWTEXT(CROSS(AA,VAR2) AND 多方能量>空方能量,49,'买');
DRAWICON(CROSS(AA,20) AND 多方能量>空方能量,30,1);
STICKLINE(CROSS(AA,20) AND 多方能量>空方能量,20,30,0.2,0),COLORRED;
DRAWICON(CROSS(AA,20) AND 多方能量>空方能量,20,13);
DRAWICON(CROSS(AA,VAR2) AND 多方能量>空方能量,0,13);
DRAWTEXT(CROSS(AA,20) AND 多方能量>空方能量,62,'加仓');
DRAWICON(CROSS(80,AA) AND 中期<80,80,14);
DRAWTEXT(CROSS(80,AA) AND 中期<80,82,'小心'),COLORGREEN;
IF(AA<=8,5,0),STICK,COLORFF00FF,LINETHICK5;
STICKLINE(CROSS(80,AA) AND 空方能量>多方能量 AND 中期<80,80,70,0.2,0),COLOR00FF00;
DRAWICON(CROSS(80,AA) AND 空方能量>多方能量 AND 中期<80,70,2);
DRAWTEXT(CROSS(80,AA) AND 空方能量>多方能量 AND 中期<80,68,'卖');
DRAWICON(短期=100 OR 中期=100 OR 中长期=100 OR 长期=100,98,42);

指标公式动态翻译

输出多方能量:7*(收盘价-27日内最低价的最低值)/(27日内最高价的最高值-27日内最低价的最低值)*30的4日[1日权重]移动平均-3*(收盘价-27日内最低价的最低值)/(27日内最高价的最高值-27日内最低价的最低值)*30的4日[1日权重]移动平均的3日[1日权重]移动平均-(收盘价-27日内最低价的最低值)/(27日内最高价的最高值-27日内最低价的最低值)*30的4日[1日权重]移动平均的3日[1日权重]移动平均的2日[1日权重]移动平均,线宽为1,画红色
输出空方能量:多方能量的5日简单移动平均的7日指数移动平均,线宽为1,画绿色
50,画红色
60,CIRCLEDOT
20,CIRCLEDOT
8,CIRCLEDOT
0
100
VAR1赋值:(收盘价-9日内最低价的最低值)/(9日内最高价的最高值-9日内最低价的最低值)*50
输出AA: (VAR1的3日指数移动平均)*2
输出布林极限:AA的3日简单移动平均
画带状线
当满足条件AA>=BB时,在53和47位置之间画柱状线,宽度为4,0不为0则画空心柱.,COLOREE82EE
当满足条件AA<BB时,在53和47位置之间画柱状线,宽度为4,1不为0则画空心柱.,COLORB3EE3A
当满足条件AA上穿20时,在58和42位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLORB23AEE
输出VAR2:8,画绿色,线宽为0
如果AA上穿VAR2,返回40,否则返回0,STICK,线宽为2
当满足条件AA上穿VAR2时,在40位置画13号图标
短期赋值:100*(收盘价-5日内最低价的最低值)/(5日内收盘价的最高值-5日内最低价的最低值),
中期赋值:100*(收盘价-10日内最低价的最低值)/(10日内收盘价的最高值-10日内最低价的最低值),
中长期赋值:100*(收盘价-20日内最低价的最低值)/(20日内收盘价的最高值-20日内最低价的最低值),
长期赋值:100*(收盘价-30日内最低价的最低值)/(30日内收盘价的最高值-30日内最低价的最低值),
输出强势线:80,DOTLINE
输出分水岭:50,DOTLINE
输出弱势线:20,DOTLINE
当满足条件中期上穿80ANDREF(中期,1)<80ANDMA(收盘价,5)>1日前的收盘价的5日简单移动平均AND多方能量>空方能量时,在中期+2位置书写文字
当满足条件长期上穿80ANDREF(长期,1)<80ANDMA(收盘价,5)>1日前的收盘价的5日简单移动平均AND多方能量>空方能量时,在中期位置书写文字
当满足条件80上穿长期ANDCROSS(80,中长期)ANDCROSS(80,中期)ANDREF(长期,1)>80ANDREF(中期,1)>80ANDREF(中长期,1)>80AND空方能量>多方能量时,在长期位置书写文字,画绿色
当满足条件80上穿短期ANDREF(短期,1)>80AND多方能量>空方能量时,在长期+2位置书写文字,画绿色
当满足条件80上穿长期ANDREF(长期,1)>80AND空方能量>多方能量时,在长期+4位置书写文字,画绿色
当满足条件80上穿短期ANDREF(短期,1)>80AND空方能量>多方能量时,在短期+2位置书写文字,画绿色
当满足条件多方能量上穿空方能量ANDREF(多方能量,1)<1日前的空方能量时,在多方能量位置画34号图标
当满足条件空方能量上穿多方能量ANDREF(多方能量,1)>1日前的空方能量时,在空方能量位置画35号图标
输出能量走势:(多方能量-空方能量)+50,线宽为2,画黄色
当满足条件AA上穿VAR2AND多方能量>空方能量时,在49位置书写文字
当满足条件AA上穿20AND多方能量>空方能量时,在30位置画1号图标
当满足条件AA上穿20AND多方能量>空方能量时,在20和30位置之间画柱状线,宽度为0.2,0不为0则画空心柱.,画红色
当满足条件AA上穿20AND多方能量>空方能量时,在20位置画13号图标
当满足条件AA上穿VAR2AND多方能量>空方能量时,在0位置画13号图标
当满足条件AA上穿20AND多方能量>空方能量时,在62位置书写文字
当满足条件80上穿AAAND中期<80时,在80位置画14号图标
当满足条件80上穿AAAND中期<80时,在82位置书写文字,画绿色
如果AA<=8,返回5,否则返回0,STICK,COLORFF00FF,线宽为5
当满足条件80上穿AAAND空方能量>多方能量AND中期<80时,在80和70位置之间画柱状线,宽度为0.2,0不为0则画空心柱.,COLOR00FF00
当满足条件80上穿AAAND空方能量>多方能量AND中期<80时,在70位置画2号图标
当满足条件80上穿AAAND空方能量>多方能量AND中期<80时,在68位置书写文字
当满足条件短期=100OR中期=100OR中长期=100OR长期=100时,在98位置画42号图标
 

多空能量妖股转世加仓指标公式用法学会了吗,中金指南网提供更多优质的通达信、同花顺指标公式,欢迎持续关注中金指南网。

相关文章