macd背离指标通达信指标公式源码

来源:中金指南网

指标公式用法

macd背离指标公式源码,如下图,为前几日低位横盘震荡买入股票,在图中出现金柱为行情正式启爆涨停,下方分为蓝柱和红柱,蓝色柱子缩短,股价下跌,呈现背离走势,底部MACD金叉,DIF上穿DEA,显示行情即将反转,经过多日盘整后行情正式启动,21日出现一字板涨停,指标虽然不是万能,当我们对看盘等知识一窍不通的时候不仅要学习,而且还可以利用一些指标公式源码帮助我们做出更准确的判断。

指标公式案例

macd背离

指标公式源码

DIF:EMA(CLOSE,12)-EMA(CLOSE,25);
DEA:EMA(DIF,5);
MACD:=(DIF-DEA)*2;
STICKLINE(MACD>0,MACD,0,2,1),COLORRED;
STICKLINE(MACD<0,MACD,0,2,1),COLORCYAN;
MACD120:REF(MACD/2,BARSLAST(MACD=HHV(MACD,120))),COLORRED,LINETHICK2;
MACD250:REF(MACD/2,BARSLAST(MACD=HHV(MACD,250))),COLORWHITE,LINETHICK2;
XG:=NOT(REF(MACD120,1)=MACD120);
STICKLINE(XG,0,MACD,2,0),COLORYELLOW;
STICKLINE(MACD>=MACD250,MACD250,MACD,2,0),COLORMAGENTA;
大行情:=NOT(REF(MACD120,1)=REF(MACD250,1)) AND MACD120=MACD250;
DRAWTEXT(XG,0,'↖金柱'),COLORYELLOW;
DRAWTEXT(大行情,0,'↖大牛启动'),COLORRED;

指标公式动态翻译

输出DIF:收盘价的12日指数移动平均-收盘价的25日指数移动平均
输出
DEA:DIF的5日指数移动平均
MACD赋值:(DIF-DEA)*2

当满足条件MACD>0时,在MACD和0位置之间画柱状线,宽度为2,1不为0则画空心柱.,画红色

当满足条件MACD<0时,在MACD和0位置之间画柱状线,宽度为2,1不为0则画空心柱.,画青色
输出
MACD120:上次MACD=120日内MACD的最高值距今天数日前的MACD/2,画红色,线宽为2
输出
MACD250:上次MACD=250日内MACD的最高值距今天数日前的MACD/2,画白色,线宽为2
XG赋值:取反

当满足条件XG时,在0和MACD位置之间画柱状线,宽度为2,0不为0则画空心柱.,画黄色

当满足条件MACD>=MACD250时,在MACD250和MACD位置之间画柱状线,宽度为2,0不为0则画空心柱.,画洋红色
大行情赋值:取反 AND MACD120=MACD250

当满足条件XG时,在0位置书写文字,画黄色

当满足条件大行情时,在0位置书写文字,画红色
 

macd背离指标用法学会了吗,中金指南网提供更多优质的通达信、同花顺指标公式,欢迎持续关注中金指南网。

相关文章