通达信kdj背离指标公式源代码

来源:中金指南网

指标公式用法

kdj背离指标公式,如下副图指标中当个股发出底背离信号时要及时关注个股转势变化。尽量选择二次确认信号更佳。

指标公式案例

kdj背离

指标公式源码

N:=19;
A0:=(2*C+H+L)/4;
RSV:=(CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100;
均线:=MA(A0,3)>REF(MA(A0,3),1);
K0:=SMA(RSV,3,1);
K2:=K0;
A1:=(CLOSE-LLV(LOW,7))/(HHV(HIGH,7)-LLV(LOW,7))*100;
A2:=EMA(WINNER(C)*100,5);
D2:=SMA(K0,2,1);
A3:=MA(SMA(C-REF(C,1),3,1)/SMA(H-REF(C,1),3,1),3)*100;
J1:(3*K0-2*D2),COLORYELLOW;
J2:MA(J1,2),COLORRED;
K:MA(3*SMA(A1,6,1)-2*SMA(SMA(A1,5,1),5,1),3),LINETHICK1,COLORYELLOW;
D:MA(K,3),COLORFF0000,LINETHICK1;
J:3*K-2*D,LINETHICK1;
MAV:=(2*C+H+L)/4;
VAR1:=LLV(LOW,21);
A4:=SMA(MAX(C-REF(C,2),0),6,1)/SMA(ABS(C-REF(C,2)),6,1)*100;
A5:=MA(3*SMA((C-LLV(L,21))/(HHV(H,21)-LLV(L,21))*100,5,
1)-2*SMA(SMA((C-LLV(L,21))/(HHV(H,21)-LLV(L,21))*100,5,1),3,1),3);
VAR2:=HHV(HIGH,21);
SK:EMA((MAV-VAR1)/(VAR2-VAR1)*100,8),COLORWHITE;
低吸:IF(CROSS(A4,14) OR A5>REF(A5,1) AND CROSS(K,A2)AND K<40,10,0);
IF(A2>80 AND CROSS(95,K),85,100);
SD:EMA(0.667*REF(SK,1)+0.333*SK,1),COLORCYAN;
SJ:=3*SK-2*SD;
跌幅较大:K<5 AND LLV(C,3)/HHV(C,20)<0.8,COLOR00FF00;
STICKLINE(跌幅较大,0,30,3,0),COLOR00FF00;
A6:=COUNT(CROSS(K,A2),2)=1 AND CROSS(K,A5)AND A5/REF(A5,1)>0.9 AND K<50;
A7:=CROSS(K,D)AND D<10 OR CROSS(K,D)AND CROSS(K,A5)AND D<18;
50,POINTDOT,COLORRED;
70,POINTDOT,COLORRED;
无限风光:A2>85 AND K>85 OR A2>90 OR K>90,LINETHICK0,COLORFFFF00;
STICKLINE(无限风光,MAX(A2,K),100,6,1),COLORFFFF00;
DRAWICON(CROSS(A3,-300)AND K<10,5,1);
90,COLOR00AA00;
WWW:SJ<20,COLOR00AA00;
A8:=BARSLAST(REF(CROSS(K,D),1));
二次金叉:=(A8<15 AND D<50 AND K>REF(K,A8+1) AND CROSS(K,D)AND A5<60);
IF(WWW,0,20),COLOR00AA00,LINETHICK2;
A9:=LLV(C,2)<REF(LLV(C,15),2);
ZDF:=(C-REF(C,2))/REF(C,2)*100>19.8 AND O>REF(C,1);
IF(ZDF,70,90),COLOR00AA00,LINETHICK2;
DRAWTEXT(二次金叉 AND A9,K,'底背离'),COLORMAGENTA;

指标公式动态翻译

N赋值:19
A0赋值:(2*收盘价+最高价+最低价)/4
RSV赋值:(收盘价-5日内最低价的最低值)/(5日内最高价的最高值-5日内最低价的最低值)*100
均线赋值:A0的3日简单移动平均>1日前的A0的3日简单移动平均
K0赋值:RSV的3日[1日权重]移动平均
K2赋值:K0
A1赋值:(收盘价-7日内最低价的最低值)/(7日内最高价的最高值-7日内最低价的最低值)*100
A2赋值:以收盘价计算的获利盘比例*100的5日指数移动平均
D2赋值:K0的2日[1日权重]移动平均
A3赋值:收盘价-1日前的收盘价的3日[1日权重]移动平均/最高价-1日前的收盘价的3日[1日权重]移动平均的3日简单移动平均*100
输出
J1:(3*K0-2*D2),画黄色
输出
J2:J1的2日简单移动平均,画红色
输出
K:3*A1的6日[1日权重]移动平均-2*A1的5日[1日权重]移动平均的5日[1日权重]移动平均的3日简单移动平均,线宽为1,画黄色
输出
D:K的3日简单移动平均,COLORFF0000,线宽为1
输出
J:3*K-2*D,线宽为1
MAV赋值:(2*收盘价+最高价+最低价)/4
VAR1赋值:21日内最低价的最低值
A4赋值:收盘价-2日前的收盘价和0的较大值的6日[1日权重]移动平均/收盘价-2日前的收盘价的绝对值的6日[1日权重]移动平均*100
A5赋值:3*(收盘价-21日内最低价的最低值)/(21日内最高价的最高值-21日内最低价的最低值)*100的5日[
1日权重]移动平均-2*(收盘价-21日内最低价的最低值)/(21日内最高价的最高值-21日内最低价的最低值)*100的5日[1日权重]移动平均的3日[1日权重]移动平均的3日简单移动平均
VAR2赋值:21日内最高价的最高值
输出
SK:(MAV-VAR1)/(VAR2-VAR1)*100的8日指数移动平均,画白色
输出
低吸:如果A4上穿14ORA5>1日前的A5ANDCROSS(K,A2)ANDK<40,返回10,否则返回0

如果A2>80ANDCROSS(95,K),返回85,否则返回100
输出
SD:0.667*1日前的SK+0.333*SK的1日指数移动平均,画青色
SJ赋值:3*SK-2*SD
输出
跌幅较大:K<5 AND 3日内收盘价的最低值/20日内收盘价的最高值<0.8,COLOR00FF00

当满足条件跌幅较大时,在0和30位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR00FF00
A6赋值:统计2日中满足K上穿A2的天数=1 AND K上穿A5AND A5/1日前的A5>0.9 AND K<50
A7赋值:K上穿DAND D<10 OR K上穿DAND K上穿A5AND D<18

50,POINTDOT,画红色

70,POINTDOT,画红色
输出
无限风光:A2>85 AND K>85 OR A2>90 OR K>90,线宽为0,COLORFFFF00

当满足条件无限风光时,在A2和K的较大值和100位置之间画柱状线,宽度为6,1不为0则画空心柱.,COLORFFFF00

当满足条件A3上穿-300ANDK<10时,在5位置画1号图标

90,COLOR00AA00
输出
WWW:SJ<20,COLOR00AA00
A8赋值:上次1日前的K上穿D距今天数
二次金叉赋值:(A8<15 AND D<50 AND K>A8+1日前的K AND K上穿DAND A5<60)

如果WWW,返回0,否则返回20,COLOR00AA00,线宽为2
A9赋值:2日内收盘价的最低值<2日前的15日内收盘价的最低值
ZDF赋值:(收盘价-2日前的收盘价)/2日前的收盘价*100>19.8 AND 开盘价>1日前的收盘价

如果ZDF,返回70,否则返回90,COLOR00AA00,线宽为2

当满足条件二次金叉ANDA9时,在K位置书写文字,画洋红色
 

kdj背离指标公式用法学会了吗,中金指南网提供更多优质的通达信、同花顺指标公式,欢迎持续关注中金指南网。

相关文章